Back to overview
Resolved

Investigating API Connectivity Issues (522 Error)

Jun 6, 2026 at 7:17pm UTC
Affected services
Server Health

Resolved
Jun 6, 2026 at 7:30pm UTC

Incident resolved. Backend is fully operational across all regions. Response times stable.

Updated
Jun 6, 2026 at 7:20pm UTC

We are seeing signs of recovery. The 522 error appears to have cleared. Monitoring closely for full resolution.

Created
Jun 6, 2026 at 7:17pm UTC

We are investigating the 522 error affecting api.viralnowapp.com/health. Likely Cloudflare connectivity issue. Updates coming shortly.